blob: 32e580583a6c6d3bf7848058647da3929af3eb6c [file] [log] [blame]
Alex Afanasyevadb89ba2023-11-17 18:58:01 +00001Index: ndn-tools_22.12-15-g7e9d7e4f-bp2/manpages/conf.py
2===================================================================
3--- ndn-tools_22.12-15-g7e9d7e4f-bp2.orig/manpages/conf.py
4+++ ndn-tools_22.12-15-g7e9d7e4f-bp2/manpages/conf.py
5@@ -1,19 +1,32 @@
6+# -*- coding: utf-8 -*-
7+#
8 # Configuration file for the Sphinx documentation builder.
9 #
10-# For the full list of built-in configuration values, see the documentation:
11-# https://www.sphinx-doc.org/en/master/usage/configuration.html
12+# This file only contains a selection of the most common options. For a full
13+# list see the documentation:
14+# http://www.sphinx-doc.org/en/master/config
15+
16+# -- Path setup --------------------------------------------------------------
17+
18+# If extensions (or modules to document with autodoc) are in another directory,
19+# add these directories to sys.path here. If the directory is relative to the
20+# documentation root, use os.path.abspath to make it absolute, like shown here.
21+#
22+# import os
23+# import sys
24+# sys.path.insert(0, os.path.abspath('.'))
25+
26
27 # -- Project information -----------------------------------------------------
28-# https://www.sphinx-doc.org/en/master/usage/configuration.html#project-information
29
30-project = 'NDN Essential Tools'
31-copyright = 'Copyright © 2014-2023 Named Data Networking Project.'
32-author = 'Named Data Networking Project'
33+project = u'NDN Essential Tools'
34+copyright = u'Copyright © 2014-2019 Named Data Networking Project.'
35+author = u'Named Data Networking Project'
36
37-# The short X.Y version.
38+# The short X.Y version
39 #version = ''
40
41-# The full version, including alpha/beta/rc tags.
42+# The full version, including alpha/beta/rc tags
43 #release = ''
44
45 # There are two options for replacing |today|: either, you set today to some
46@@ -24,26 +37,34 @@ today_fmt = '%Y-%m-%d'
47
48
49 # -- General configuration ---------------------------------------------------
50-# https://www.sphinx-doc.org/en/master/usage/configuration.html#general-configuration
51
52-needs_sphinx = '4.0'
53-extensions = []
54+# If your documentation needs a minimal Sphinx version, state it here.
55+#
56+needs_sphinx = '1.1'
57
58-templates_path = ['_templates']
59-exclude_patterns = ['Thumbs.db', '.DS_Store']
60+# Add any Sphinx extension module names here, as strings. They can be
61+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
62+# ones.
63+extensions = [
64+]
65+
66+# The master toctree document.
67+master_doc = 'index'
68
69
70 # -- Options for manual page output ------------------------------------------
71-# https://www.sphinx-doc.org/en/master/usage/configuration.html#options-for-manual-page-output
72
73 # One entry per manual page. List of tuples
74 # (source start file, name, description, authors, manual section).
75 man_pages = [
76- ('ndnpeek', 'ndnpeek', 'simple consumer to send one Interest and receive one Data', [], 1),
77- ('ndnpoke', 'ndnpoke', 'simple producer to publish one Data', [], 1),
78- ('ndnping', 'ndnping', 'reachability testing client', [], 1),
79- ('ndnpingserver', 'ndnpingserver', 'reachability testing server', [], 1),
80- ('ndnputchunks', 'ndnputchunks', 'producer program with content segmentation', [], 1),
81- ('ndndump', 'ndndump', 'traffic analysis tool', [], 8),
82- ('ndn-dissect', 'ndn-dissect', 'NDN packet format inspector', [], 1),
83+ ('ndnpeek', 'ndnpeek', 'simple consumer to send one Interest and expect one Data', [], 1),
84+ ('ndnpoke', 'ndnpoke', 'simple producer to publish one Data', [], 1),
85+ ('ndnping', 'ndnping', 'reachability testing client', [], 1),
86+ ('ndnpingserver', 'ndnpingserver', 'reachability testing server', [], 1),
87+ ('ndnputchunks', 'ndnputchunks', 'producer program with content segmentation', [], 1),
88+ ('ndndump', 'ndndump', 'traffic analysis tool', [], 8),
89+ ('ndn-dissect', 'ndn-dissect', 'NDN packet format inspector', [], 1),
90 ]
91+
92+# If true, show URL addresses after external links.
93+#man_show_urls = True