blob: afa8054e97f712ab98810bbce8a87bcbfd799e84 [file] [log] [blame]
Alexander Afanasyev288311c2014-09-05 09:52:28 -07001Index: ndn-cxx_0.2.0-1/docs/conf.py
2===================================================================
3--- ndn-cxx_0.2.0-1.orig/docs/conf.py 2014-09-04 22:28:44.422356062 -0700
4+++ ndn-cxx_0.2.0-1/docs/conf.py 2014-09-04 23:11:35.051297075 -0700
5@@ -254,7 +254,7 @@
6 ('tutorials/security-validator-config', 'ndnsec-validator.conf',
7 'NDN trust validator configuration file', None, 5),
8 ('manpages/tlvdump', 'tlvdump', 'Decode structure of TLV encoded buffer', None, 1),
9- ('manpages/client.conf', 'client.conf', 'Configuration file for NDN platform', None, 5),
10+ ('manpages/ndn-client.conf', 'ndn-client.conf', 'Configuration file for NDN platform', None, 5),
11 ]
12
13
14Index: ndn-cxx_0.2.0-1/docs/manpages.rst
15===================================================================
16--- ndn-cxx_0.2.0-1.orig/docs/manpages.rst 2014-09-04 22:28:44.422356062 -0700
17+++ ndn-cxx_0.2.0-1/docs/manpages.rst 2014-09-04 23:11:21.095296452 -0700
18@@ -2,7 +2,7 @@
19 ========
20
21 .. toctree::
22- manpages/client.conf
23+ manpages/ndn-client.conf
24 manpages/ndnsec
25 ndnsec-list <manpages/ndnsec-list>
26 ndnsec-get-default <manpages/ndnsec-get-default>
27Index: ndn-cxx_0.2.0-1/docs/manpages/client.conf.rst
28===================================================================
29--- ndn-cxx_0.2.0-1.orig/docs/manpages/client.conf.rst 2014-09-04 22:28:44.422356062 -0700
30+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
31@@ -1,67 +0,0 @@
32-client.conf
33-===========
34-
35-System configuration of NDN platform is specified in ``client.conf``.
36-Here is an example of ``client.conf`` for current ndn-cxx package:
37-
38-::
39-
40- ; "unix_socket" specifies the location of the NFD unix socket
41- unix_socket=/var/run/nfd.sock
42-
43- ; "protocol" determines the protocol for prefix registration
44- ; it has a value of:
45- ; nrd-0.1
46- protocol=nrd-0.1
47-
48- ; "pib" determines which Public Info Base (PIB) should used by default in applications.
49- ; If "pib" is not specified, the default PIB will be used.
50- ; Note that default PIB could be different on different system.
51- ; If "pib" is specified, it may have a value of:
52- ; sqlite3
53- ; pib=sqlite3
54-
55- ; "tpm" determines which Trusted Platform Module (TPM) should used by default in applications.
56- ; If "tpm" is not specified, the default TPM will be used.
57- ; Note that default TPM could be different on different system.
58- ; If "tpm" is specified, it may have a value of:
59- ; file
60- ; osx-keychain
61- ; tpm=file
62-
63-NFD
64----
65-
66-unix_socket
67- The local interface of NFD to applications. By default, the path to the socket is ``/var/run/nfd.sock``.
68-
69-Prefix Registration
70--------------------
71-
72-protocol
73- The prefix registration protocol. For now, only one protocol ``nrd-0.1`` is supported.
74- With this protocol, applications send prefix registration requests to NRD.
75- NRD, after authenticating the request, will set up corresponding FIB entries in NFD.
76-
77-Key Management
78---------------
79-
80-tpm
81- Trusted Platform Module (TPM) where the private keys are stored.
82- Two options are currently available: ``file`` and ``osx-keychain``.
83- **Users are not supposed to change the ``tpm`` setting once it is configued,
84- otherwise users may face the problem of "Keys are not found".**
85- The default value of ``tpm`` depends on the operating system.
86- For OS X, the default value is ``osx-keychain``.
87- For other systems, the default value is ``file``.
88-
89-pib
90- The public key information for each private key stored in TPM.
91- There is only one option for ``pib``: ``sqlite3``, which is also the default value of ``pib``.
92-
93-Users are not supposed to change the configuration of Key Management.
94-If changes is inevitable, please clean up the all the existing data (which is usually under ``~/.ndn/``):
95-
96-::
97-
98- rm -rf ~/.ndn/ndnsec-*
99Index: ndn-cxx_0.2.0-1/docs/manpages/ndn-client.conf.rst
100===================================================================
101--- /dev/null 1970-01-01 00:00:00.000000000 +0000
102+++ ndn-cxx_0.2.0-1/docs/manpages/ndn-client.conf.rst 2014-09-04 22:28:44.422356062 -0700
103@@ -0,0 +1,67 @@
104+client.conf
105+===========
106+
107+System configuration of NDN platform is specified in ``client.conf``.
108+Here is an example of ``client.conf`` for current ndn-cxx package:
109+
110+::
111+
112+ ; "unix_socket" specifies the location of the NFD unix socket
113+ unix_socket=/var/run/nfd.sock
114+
115+ ; "protocol" determines the protocol for prefix registration
116+ ; it has a value of:
117+ ; nrd-0.1
118+ protocol=nrd-0.1
119+
120+ ; "pib" determines which Public Info Base (PIB) should used by default in applications.
121+ ; If "pib" is not specified, the default PIB will be used.
122+ ; Note that default PIB could be different on different system.
123+ ; If "pib" is specified, it may have a value of:
124+ ; sqlite3
125+ ; pib=sqlite3
126+
127+ ; "tpm" determines which Trusted Platform Module (TPM) should used by default in applications.
128+ ; If "tpm" is not specified, the default TPM will be used.
129+ ; Note that default TPM could be different on different system.
130+ ; If "tpm" is specified, it may have a value of:
131+ ; file
132+ ; osx-keychain
133+ ; tpm=file
134+
135+NFD
136+---
137+
138+unix_socket
139+ The local interface of NFD to applications. By default, the path to the socket is ``/var/run/nfd.sock``.
140+
141+Prefix Registration
142+-------------------
143+
144+protocol
145+ The prefix registration protocol. For now, only one protocol ``nrd-0.1`` is supported.
146+ With this protocol, applications send prefix registration requests to NRD.
147+ NRD, after authenticating the request, will set up corresponding FIB entries in NFD.
148+
149+Key Management
150+--------------
151+
152+tpm
153+ Trusted Platform Module (TPM) where the private keys are stored.
154+ Two options are currently available: ``file`` and ``osx-keychain``.
155+ **Users are not supposed to change the ``tpm`` setting once it is configued,
156+ otherwise users may face the problem of "Keys are not found".**
157+ The default value of ``tpm`` depends on the operating system.
158+ For OS X, the default value is ``osx-keychain``.
159+ For other systems, the default value is ``file``.
160+
161+pib
162+ The public key information for each private key stored in TPM.
163+ There is only one option for ``pib``: ``sqlite3``, which is also the default value of ``pib``.
164+
165+Users are not supposed to change the configuration of Key Management.
166+If changes is inevitable, please clean up the all the existing data (which is usually under ``~/.ndn/``):
167+
168+::
169+
170+ rm -rf ~/.ndn/ndnsec-*