blob: 762e69415b6414736424e1732cc167cc9d806c2e [file] [log] [blame]
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +00001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyev7c8f49f2018-10-16 16:42:14 +000014CXXFLAGS += -std=c++14
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +000015LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
16
17%:
18 dh $@ --parallel
19
20override_dh_auto_configure:
21 ./waf configure --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --boost-libs="$(LIBDIR)"
22
23override_dh_auto_build:
24 ./waf build
25
26override_dh_auto_install:
27 ./waf install --destdir=debian/tmp
28
29override_dh_auto_clean:
30 ./waf distclean
31
32override_dh_clean:
33 dh_clean
34 ./waf distclean
35 rm -rf .waf-1*
36 rm -f .waf-tools/*.pyc
37 rm -f docs/*.pyc
Alex Afanasyevd746bcf2020-11-22 22:04:37 +000038 rm -rf .waf-tools/__pycache__
39 rm -rf docs/__pycache__
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +000040
41override_dh_auto_test:
42
43.PHONY: override_dh_strip
44override_dh_strip:
45 dh_strip --dbg-package=libchronosync-dbg