blob: 37e2948963ee9621078ee807e29a790705d9131a [file] [log] [blame]
Alexander Afanasyev52c1c052014-09-04 16:13:14 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13
14%:
15 dh $@ --parallel
16
17override_dh_auto_configure:
18 cd ChronoSync; \
19 ./waf configure --prefix=../debian/tmp2/chronosync; \
20 ./waf build; \
21 ./waf install; \
22
23 PKG_CONFIG_PATH=debian/tmp2/chronosync/lib/pkgconfig:$PKG_CONFIG_PATH \
24 ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
25
26override_dh_auto_build:
27 ./waf build
28
29override_dh_auto_install:
30 PKG_CONFIG_PATH=debian/tmp2/chronosync/lib/pkgconfig:$PKG_CONFIG_PATH \
31 ./waf install --destdir=debian/chronochat
32
33override_dh_auto_clean:
34 ./waf distclean
35
36override_dh_clean:
37 dh_clean
38 cd ChronoSync; \
39 ./waf distclean; \
40 rm -rf .waf-1*; \
41 rm -rf .waf3-1*; \
42 rm -f .waf-tools/*.pyc; \
43 rm -f waf-tools/*.pyc
44
45 ./waf distclean
46 rm -rf .waf-1*
47 rm -rf .waf3-1*
48 rm -f .waf-tools/*.pyc
49 rm -f waf-tools/*.pyc
50
51override_dh_auto_test: