Alexander Afanasyev | b4da9eb | 2014-05-24 16:52:17 -0700 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # -*- makefile -*- |
| 3 | # Sample debian/rules that uses debhelper. |
| 4 | # This file was originally written by Joey Hess and Craig Small. |
| 5 | # As a special exception, when this file is copied by dh-make into a |
| 6 | # dh-make output file, you may use that output file without restriction. |
| 7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
| 8 | |
| 9 | # Uncomment this to turn on verbose mode. |
| 10 | # export DH_VERBOSE=1 |
| 11 | |
| 12 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
| 13 | |
| 14 | %: |
| 15 | dh $@ --parallel |
| 16 | |
| 17 | override_dh_auto_configure: |
| 18 | ./waf --nocache configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var |
| 19 | |
| 20 | override_dh_auto_build: |
| 21 | ./waf --nocache build |
| 22 | |
| 23 | override_dh_auto_install: |
| 24 | ./waf install --destdir=debian/tmp |
| 25 | |
| 26 | override_dh_auto_clean: |
| 27 | ./waf distclean |
| 28 | |
| 29 | override_dh_clean: |
| 30 | dh_clean |
| 31 | ./waf distclean |
| 32 | rm -rf .waf-1* |
| 33 | rm -rf .waf3-1* |
| 34 | rm -f .waf-tools/*.pyc |
| 35 | |
| 36 | override_dh_auto_test: |