Alexander Afanasyev | 94c793a | 2015-07-23 04:11:36 +0000 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # -*- makefile -*- |
| 3 | # Sample debian/rules that uses debhelper. |
| 4 | # This file was originally written by Joey Hess and Craig Small. |
| 5 | # As a special exception, when this file is copied by dh-make into a |
| 6 | # dh-make output file, you may use that output file without restriction. |
| 7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
| 8 | |
| 9 | # Uncomment this to turn on verbose mode. |
| 10 | # export DH_VERBOSE=1 |
| 11 | |
| 12 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
| 13 | CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS) |
| 14 | |
| 15 | %: |
| 16 | dh $@ --parallel --with=systemd |
| 17 | |
| 18 | override_dh_auto_configure: |
| 19 | CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr |
| 20 | |
| 21 | override_dh_auto_build: |
| 22 | ./waf build |
| 23 | |
| 24 | override_dh_auto_install: |
| 25 | ./waf install --destdir=debian/tmp |
| 26 | |
| 27 | override_dh_auto_clean: |
| 28 | ./waf distclean |
| 29 | |
| 30 | override_dh_clean: |
| 31 | dh_clean |
| 32 | ./waf distclean |
| 33 | rm -rf .waf-1* |
| 34 | rm -rf .waf3-1* |
| 35 | rm -f .waf-tools/*.pyc |
| 36 | rm -Rf manpages/*.pyc |
| 37 | |
| 38 | override_dh_auto_test: |