blob: 79f988dd2298166a37ca995399a31c6376404fae [file] [log] [blame]
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13
14%:
15 dh $@ --parallel
16
17override_dh_auto_configure:
Alexander Afanasyev2c3726b2014-05-26 06:29:36 -070018 ./waf configure --prefix=/usr
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -070019
20override_dh_auto_build:
Alexander Afanasyev2c3726b2014-05-26 06:29:36 -070021 ./waf build
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -070022
23override_dh_auto_install:
24 ./waf install --destdir=debian/tmp
25
26override_dh_auto_clean:
27 ./waf distclean
28
29override_dh_clean:
30 dh_clean
31 ./waf distclean
32 rm -rf .waf-1*
33 rm -rf .waf3-1*
34 rm -f .waf-tools/*.pyc
35
36override_dh_auto_test: