blob: b94084aba973da6a74633d23ea49b9913cde4a58 [file] [log] [blame]
Syed Obaidacc28bc2014-06-24 17:13:33 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Alexander Afanasyevbcda63a2017-01-26 05:24:28 +000015LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Syed Obaidacc28bc2014-06-24 17:13:33 -070016
17%:
Eric Newberry8149f772015-06-09 14:12:19 -070018 dh $@ --parallel --with=systemd
Syed Obaidacc28bc2014-06-24 17:13:33 -070019
20override_dh_auto_configure:
Alexander Afanasyevbcda63a2017-01-26 05:24:28 +000021 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --boost-libs="$(LIBDIR)"
Syed Obaidacc28bc2014-06-24 17:13:33 -070022
23override_dh_auto_build:
24 ./waf build
25
26override_dh_auto_install:
27 ./waf install --destdir=debian/tmp
28
29override_dh_auto_clean:
30 ./waf distclean
31
32override_dh_clean:
33 dh_clean
34 ./waf distclean
Alexander Afanasyev34412062014-08-25 12:35:54 -070035 rm -f VERSION
Syed Obaidacc28bc2014-06-24 17:13:33 -070036 rm -rf .waf-1*
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080037 rm -rf .waf3-1*
Syed Obaidacc28bc2014-06-24 17:13:33 -070038 rm -f .waf-tools/*.pyc
Alexander Afanasyev34412062014-08-25 12:35:54 -070039 rm -f docs/*.pyc
Syed Obaidacc28bc2014-06-24 17:13:33 -070040
41override_dh_auto_test:
Eric Newberry8149f772015-06-09 14:12:19 -070042
43override_dh_systemd_enable:
44 dh_systemd_enable --no-enable
45
46override_dh_systemd_start:
47 dh_systemd_start --no-start