blob: 162b6a6311431da2a10603d6d829cc3a679a8d2a [file] [log] [blame]
Syed Obaidacc28bc2014-06-24 17:13:33 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyevbcda63a2017-01-26 05:24:28 +000014LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Syed Obaidacc28bc2014-06-24 17:13:33 -070015
16%:
Eric Newberry8149f772015-06-09 14:12:19 -070017 dh $@ --parallel --with=systemd
Syed Obaidacc28bc2014-06-24 17:13:33 -070018
19override_dh_auto_configure:
Ashlesh Gawande8e8cb552018-01-13 14:39:59 -060020 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --boost-libs="$(LIBDIR)" --sysconfdir=/etc
Syed Obaidacc28bc2014-06-24 17:13:33 -070021
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
Alexander Afanasyev34412062014-08-25 12:35:54 -070034 rm -f VERSION
Syed Obaidacc28bc2014-06-24 17:13:33 -070035 rm -rf .waf-1*
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080036 rm -rf .waf3-1*
Syed Obaidacc28bc2014-06-24 17:13:33 -070037 rm -f .waf-tools/*.pyc
Alexander Afanasyev34412062014-08-25 12:35:54 -070038 rm -f docs/*.pyc
Alex Afanasyevfeee11e2020-11-23 01:42:03 +000039 rm -rf .waf-tools/__pycache__
40 rm -rf docs/__pycache__
Syed Obaidacc28bc2014-06-24 17:13:33 -070041
42override_dh_auto_test:
Eric Newberry8149f772015-06-09 14:12:19 -070043
44override_dh_systemd_enable:
45 dh_systemd_enable --no-enable
46
47override_dh_systemd_start:
48 dh_systemd_start --no-start