blob: a136bd962a3660e3fe36090263bbb73cf2ec3b1c [file] [log] [blame]
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyeva178b8b2014-12-18 23:09:18 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -070015
16%:
17 dh $@ --parallel
18
19override_dh_auto_configure:
Alexander Afanasyeva178b8b2014-12-18 23:09:18 -080020 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -070021
22override_dh_auto_build:
Alexander Afanasyev2c3726b2014-05-26 06:29:36 -070023 ./waf build
Alexander Afanasyevf371f7d2014-05-24 17:07:01 -070024
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -rf .waf3-1*
36 rm -f .waf-tools/*.pyc
37
38override_dh_auto_test: