blob: 9cb89e552b0c38868cc32f8a05b5843ea864798b [file] [log] [blame]
Syed Obaidacc28bc2014-06-24 17:13:33 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Syed Obaidacc28bc2014-06-24 17:13:33 -070015
16%:
Eric Newberry8149f772015-06-09 14:12:19 -070017 dh $@ --parallel --with=systemd
Syed Obaidacc28bc2014-06-24 17:13:33 -070018
19override_dh_auto_configure:
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080020 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr
Syed Obaidacc28bc2014-06-24 17:13:33 -070021
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
Alexander Afanasyev34412062014-08-25 12:35:54 -070034 rm -f VERSION
Syed Obaidacc28bc2014-06-24 17:13:33 -070035 rm -rf .waf-1*
Alexander Afanasyevf1889a72014-12-18 23:38:12 -080036 rm -rf .waf3-1*
Syed Obaidacc28bc2014-06-24 17:13:33 -070037 rm -f .waf-tools/*.pyc
Alexander Afanasyev34412062014-08-25 12:35:54 -070038 rm -f docs/*.pyc
Syed Obaidacc28bc2014-06-24 17:13:33 -070039
40override_dh_auto_test:
Eric Newberry8149f772015-06-09 14:12:19 -070041
42override_dh_systemd_enable:
43 dh_systemd_enable --no-enable
44
45override_dh_systemd_start:
46 dh_systemd_start --no-start