blob: 002775d57332e718926578da40f4488804ba6f0c [file] [log] [blame]
Alexander Afanasyev6397d532014-05-07 19:25:04 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyev3859a9c2014-11-09 16:51:45 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Alexander Afanasyev6397d532014-05-07 19:25:04 -070015
16%:
17 dh $@ --parallel
18
19override_dh_auto_configure:
Alexander Afanasyev27cb57e2015-07-02 00:41:23 +000020 ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static --enable-shared
Alexander Afanasyev6397d532014-05-07 19:25:04 -070021
22override_dh_auto_build:
Alexander Afanasyev0e5319c2014-06-19 12:41:24 -070023 ./waf build
Alexander Afanasyev6397d532014-05-07 19:25:04 -070024
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
Alexander Afanasyev6397d532014-05-07 19:25:04 -070034 rm -rf .waf-1*
35 rm -f .waf-tools/*.pyc
36 rm -f docs/*.pyc
37
38override_dh_auto_test: