blob: 10c8740651f17d290f05d93b1874aa9cfde922f0 [file] [log] [blame]
Zhiyi Zhang4f1cfbc2018-01-17 16:38:40 -08001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
15LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
16
17%:
18 dh $@ --parallel
19
20override_dh_auto_configure:
21 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --boost-libs="$(LIBDIR)"
22
23override_dh_auto_build:
24 ./waf build
25
26override_dh_auto_install:
27 ./waf install --destdir=debian/tmp
28
29override_dh_auto_clean:
30 ./waf distclean
31
32override_dh_clean:
33 dh_clean
34 ./waf distclean
35 rm -rf .waf-1*
36 rm -rf .waf3-1*
37 rm -f .waf-tools/*.pyc
38
39override_dh_auto_test:
40
41.PHONY: override_dh_strip
42override_dh_strip:
43 dh_strip --dbg-package=libndncert-dbg