blob: f702921ff1405e749e6139ae36e6fb7a9ca24786 [file] [log] [blame]
Shock Jiang010a4ae2014-11-26 14:55:19 -08001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyev24acc842017-01-26 05:45:20 +000014LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Shock Jiang010a4ae2014-11-26 14:55:19 -080015
16%:
Eric Newberry9e3822a2015-06-09 14:07:02 -070017 dh $@ --parallel --with=systemd
Shock Jiang010a4ae2014-11-26 14:55:19 -080018
19override_dh_auto_configure:
Davide Pesavento4fbb1b72019-01-22 17:58:51 -050020 LDFLAGS="${LDFLAGS}" CXXFLAGS="$(CXXFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --boost-libs="$(LIBDIR)"
Shock Jiang010a4ae2014-11-26 14:55:19 -080021
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -rf .waf3-1*
36 rm -f .waf-tools/*.pyc
37 rm -f docs/*.pyc
Alex Afanasyev34a2e782022-02-17 21:37:21 +000038 rm -rf .waf-tools/__pycache__
Shock Jiang010a4ae2014-11-26 14:55:19 -080039
40override_dh_auto_test:
Eric Newberry9e3822a2015-06-09 14:07:02 -070041
42override_dh_systemd_enable:
43 dh_systemd_enable --no-enable
44
45override_dh_systemd_start:
46 dh_systemd_start --no-start
47