blob: 6d7eee7d11e5668c400de15758c2224cb53d3690 [file] [log] [blame]
Junxiao Shibdc817e2020-08-08 17:16:34 -06001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4#export DH_VERBOSE = 1
5
Junxiao Shibdc817e2020-08-08 17:16:34 -06006LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
7CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Junxiao Shibdc817e2020-08-08 17:16:34 -06008LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
9
10%:
11 dh $@ --parallel
12
13override_dh_auto_configure:
14 ./waf configure --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --boost-libs="$(LIBDIR)"
15
16override_dh_auto_build:
17 ./waf build
18
19override_dh_auto_install:
20 ./waf install --destdir=debian/tmp
21
22override_dh_auto_clean:
23 ./waf distclean
24
25override_dh_clean:
26 dh_clean
27 ./waf distclean
28 rm -rf .waf-1*
29 rm -f .waf-tools/*.pyc
30 rm -f docs/*.pyc
Alex Afanasyev605d06c2020-11-23 01:42:48 +000031 rm -rf .waf-tools/__pycache__
32 rm -rf docs/__pycache__
Junxiao Shibdc817e2020-08-08 17:16:34 -060033
34override_dh_auto_test:
35
36.PHONY: override_dh_strip
37override_dh_strip:
38 dh_strip --dbg-package=libndn-nac-dbg