blob: 97288fae4c8280c97a0444992396cd343622eae3 [file] [log] [blame]
Alexander Afanasyevb4da9eb2014-05-24 16:52:17 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
Alexander Afanasyev2cc04552014-12-18 23:04:01 -080013CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Alexander Afanasyev4bed6612017-01-26 05:45:04 +000015LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Alexander Afanasyevb4da9eb2014-05-24 16:52:17 -070016
17%:
Eric Newberry01762d42015-06-09 14:14:28 -070018 dh $@ --parallel --with=systemd
Alexander Afanasyevb4da9eb2014-05-24 16:52:17 -070019
20override_dh_auto_configure:
Alexander Afanasyev4bed6612017-01-26 05:45:04 +000021 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --boost-libs="$(LIBDIR)"
Alexander Afanasyevb4da9eb2014-05-24 16:52:17 -070022
23override_dh_auto_build:
Alexander Afanasyev2c3726b2014-05-26 06:29:36 -070024 ./waf build
Alexander Afanasyevb4da9eb2014-05-24 16:52:17 -070025
26override_dh_auto_install:
27 ./waf install --destdir=debian/tmp
28
29override_dh_auto_clean:
30 ./waf distclean
31
32override_dh_clean:
33 dh_clean
34 ./waf distclean
35 rm -rf .waf-1*
36 rm -rf .waf3-1*
37 rm -f .waf-tools/*.pyc
38
39override_dh_auto_test: