blob: fef68d04b1d864f2dcd9f21864e7687b4454a4d5 [file] [log] [blame]
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +00001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +000014LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
15
16%:
17 dh $@ --parallel
18
19override_dh_auto_configure:
20 ./waf configure --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --boost-libs="$(LIBDIR)"
21
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -f .waf-tools/*.pyc
36 rm -f docs/*.pyc
Alex Afanasyevd746bcf2020-11-22 22:04:37 +000037 rm -rf .waf-tools/__pycache__
38 rm -rf docs/__pycache__
Alexander Afanasyevbcbbc952017-06-12 23:05:19 +000039
40override_dh_auto_test:
41
42.PHONY: override_dh_strip
43override_dh_strip:
44 dh_strip --dbg-package=libchronosync-dbg