blob: 44c87df80b9e4bf98174e1ff92a11dae432bcd9e [file] [log] [blame]
Syed Obaidacc28bc2014-06-24 17:13:33 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13
14%:
15 dh $@ --parallel
16
17override_dh_auto_configure:
18 ./waf configure --prefix=/usr
19
20override_dh_auto_build:
21 ./waf build
22
23override_dh_auto_install:
24 ./waf install --destdir=debian/tmp
25
26override_dh_auto_clean:
27 ./waf distclean
28
29override_dh_clean:
30 dh_clean
31 ./waf distclean
Alexander Afanasyev34412062014-08-25 12:35:54 -070032 rm -f VERSION
Syed Obaidacc28bc2014-06-24 17:13:33 -070033 rm -rf .waf-1*
34 rm -f .waf-tools/*.pyc
Alexander Afanasyev34412062014-08-25 12:35:54 -070035 rm -f docs/*.pyc
Syed Obaidacc28bc2014-06-24 17:13:33 -070036
37override_dh_auto_test: