blob: aa72278cd2d740faa4d2fef9acc04833c1622419 [file] [log] [blame]
Alexander Afanasyev3859a9c2014-11-09 16:51:45 -08001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++0x
15
16%:
17 dh $@ --parallel
18
19override_dh_auto_configure:
20 ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
21
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -f .waf-tools/*.pyc
36 rm -f docs/*.pyc
37
38override_dh_auto_test: