blob: 20128ae2c8753d88d10d353fceefcec0b7db71b1 [file] [log] [blame]
Alexander Afanasyev94c793a2015-07-23 04:11:36 +00001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyevdc8114b2017-01-26 04:30:19 +000014LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Alexander Afanasyev94c793a2015-07-23 04:11:36 +000015
16%:
17 dh $@ --parallel --with=systemd
18
19override_dh_auto_configure:
Alexander Afanasyevdc8114b2017-01-26 04:30:19 +000020 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --boost-libs="$(LIBDIR)"
Alexander Afanasyev94c793a2015-07-23 04:11:36 +000021
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -rf .waf3-1*
36 rm -f .waf-tools/*.pyc
37 rm -Rf manpages/*.pyc
Alex Afanasyev69423d42020-11-23 01:42:21 +000038 rm -rf .waf-tools/__pycache__
39 rm -rf docs/__pycache__
40 rm -rf manpages/__pycache__
Alexander Afanasyev94c793a2015-07-23 04:11:36 +000041
42override_dh_auto_test: