blob: 08cd289717a8e1ddca07e8eda2be21375262407f [file] [log] [blame]
Alexander Afanasyev6397d532014-05-07 19:25:04 -07001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13
14%:
15 dh $@ --parallel
16
17override_dh_auto_configure:
Alexander Afanasyev0e5319c2014-06-19 12:41:24 -070018 ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
Alexander Afanasyev6397d532014-05-07 19:25:04 -070019
20override_dh_auto_build:
Alexander Afanasyev0e5319c2014-06-19 12:41:24 -070021 ./waf build
Alexander Afanasyev6397d532014-05-07 19:25:04 -070022
23override_dh_auto_install:
24 ./waf install --destdir=debian/tmp
25
26override_dh_auto_clean:
27 ./waf distclean
28
29override_dh_clean:
30 dh_clean
31 ./waf distclean
32 rm -rf .waf-1*
33 rm -f .waf-tools/*.pyc
34 rm -f docs/*.pyc
35
36override_dh_auto_test: