jdehart1 | 4dbffd6 | 2016-06-27 14:34:17 -0500 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # -*- makefile -*- |
| 3 | # Sample debian/rules that uses debhelper. |
| 4 | # This file was originally written by Joey Hess and Craig Small. |
| 5 | # As a special exception, when this file is copied by dh-make into a |
| 6 | # dh-make output file, you may use that output file without restriction. |
| 7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
| 8 | |
| 9 | # Uncomment this to turn on verbose mode. |
| 10 | # export DH_VERBOSE=1 |
| 11 | |
| 12 | LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
| 13 | CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS) |
Alexander Afanasyev | 7eec426 | 2017-01-26 05:30:19 +0000 | [diff] [blame] | 14 | LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH) |
jdehart1 | 4dbffd6 | 2016-06-27 14:34:17 -0500 | [diff] [blame] | 15 | |
| 16 | %: |
| 17 | dh $@ --parallel --with=systemd |
| 18 | |
| 19 | override_dh_auto_configure: |
Alexander Afanasyev | 7eec426 | 2017-01-26 05:30:19 +0000 | [diff] [blame] | 20 | CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --boost-libs="$(LIBDIR)" |
jdehart1 | 4dbffd6 | 2016-06-27 14:34:17 -0500 | [diff] [blame] | 21 | |
| 22 | override_dh_auto_build: |
| 23 | ./waf build |
| 24 | |
| 25 | override_dh_auto_install: |
| 26 | ./waf install --destdir=debian/tmp |
| 27 | |
| 28 | override_dh_auto_clean: |
| 29 | ./waf distclean |
| 30 | |
| 31 | override_dh_clean: |
| 32 | dh_clean |
| 33 | ./waf distclean |
| 34 | rm -rf .waf-1* |
| 35 | rm -rf .waf3-1* |
| 36 | rm -f .waf-tools/*.pyc |
Alex Afanasyev | 995b4d9 | 2020-11-23 01:42:59 +0000 | [diff] [blame] | 37 | rm -rf .waf-tools/__pycache__ |
| 38 | rm -rf docs/__pycache__ |
jdehart1 | 4dbffd6 | 2016-06-27 14:34:17 -0500 | [diff] [blame] | 39 | |
| 40 | override_dh_auto_test: |