blob: f0fb8ef3913b755dbf8a7f9f55d229187dac109e [file] [log] [blame]
jdehart14dbffd62016-06-27 14:34:17 -05001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
Alexander Afanasyev7eec4262017-01-26 05:30:19 +000014LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
jdehart14dbffd62016-06-27 14:34:17 -050015
16%:
17 dh $@ --parallel --with=systemd
18
19override_dh_auto_configure:
Alexander Afanasyev7eec4262017-01-26 05:30:19 +000020 CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --boost-libs="$(LIBDIR)"
jdehart14dbffd62016-06-27 14:34:17 -050021
22override_dh_auto_build:
23 ./waf build
24
25override_dh_auto_install:
26 ./waf install --destdir=debian/tmp
27
28override_dh_auto_clean:
29 ./waf distclean
30
31override_dh_clean:
32 dh_clean
33 ./waf distclean
34 rm -rf .waf-1*
35 rm -rf .waf3-1*
36 rm -f .waf-tools/*.pyc
Alex Afanasyev995b4d92020-11-23 01:42:59 +000037 rm -rf .waf-tools/__pycache__
38 rm -rf docs/__pycache__
jdehart14dbffd62016-06-27 14:34:17 -050039
40override_dh_auto_test: