blob: 4006ae86cb0a8d9176544cb829e84eca6faa8cce [file] [log] [blame]
Ashlesh Gawande64ad7302019-01-14 19:07:51 -06001#!/usr/bin/make -f
2# See debhelper(7) (uncomment to enable)
3# output every command that modifies files on the build system.
4#export DH_VERBOSE = 1
5
6
7LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
8CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
9CXXFLAGS += -std=c++14
10LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
11
12%:
13 dh $@ --parallel
14
15override_dh_auto_configure:
16 ./waf configure --with-examples --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --boost-libs="$(LIBDIR)"
17
18override_dh_auto_build:
19 ./waf build
20
21override_dh_auto_install:
22 ./waf install --destdir=debian/tmp
23
24override_dh_auto_clean:
25 ./waf distclean
26
27override_dh_clean:
28 dh_clean
29 ./waf distclean
30 rm -rf .waf-1*
31 rm -f .waf-tools/*.pyc
32 rm -f docs/*.pyc
33
34override_dh_auto_test:
35
36.PHONY: override_dh_strip
37override_dh_strip:
38 dh_strip --dbg-package=libpsync-dbg
39