blob: f2469a3652fa8949d232651a07faf30d1685de58 [file] [log] [blame]
Shock Jiang010a4ae2014-11-26 14:55:19 -08001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10# export DH_VERBOSE=1
11
12LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
13CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
14CXXFLAGS += -std=c++11
Alexander Afanasyev24acc842017-01-26 05:45:20 +000015LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
Shock Jiang010a4ae2014-11-26 14:55:19 -080016
17%:
Eric Newberry9e3822a2015-06-09 14:07:02 -070018 dh $@ --parallel --with=systemd
Shock Jiang010a4ae2014-11-26 14:55:19 -080019
20override_dh_auto_configure:
Alexander Afanasyev24acc842017-01-26 05:45:20 +000021 LDFLAGS="${LDFLAGS}" CXXFLAGS="$(CXXFLAGS)" ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --boost-libs="$(LIBDIR)"
Shock Jiang010a4ae2014-11-26 14:55:19 -080022
23override_dh_auto_build:
24 ./waf build
25
26override_dh_auto_install:
27 ./waf install --destdir=debian/tmp
28
29override_dh_auto_clean:
30 ./waf distclean
31
32override_dh_clean:
33 dh_clean
34 ./waf distclean
35 rm -rf .waf-1*
36 rm -rf .waf3-1*
37 rm -f .waf-tools/*.pyc
38 rm -f docs/*.pyc
39
40override_dh_auto_test:
Eric Newberry9e3822a2015-06-09 14:07:02 -070041
42override_dh_systemd_enable:
43 dh_systemd_enable --no-enable
44
45override_dh_systemd_start:
46 dh_systemd_start --no-start
47