| # Sample debian/rules that uses debhelper. |
| # This file was originally written by Joey Hess and Craig Small. |
| # As a special exception, when this file is copied by dh-make into a |
| # dh-make output file, you may use that output file without restriction. |
| # This special exception was added by Craig Small in version 0.37 of dh-make. |
| # Uncomment this to turn on verbose mode. |
| LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) |
| CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS) |
| LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH) |
| override_dh_auto_configure: |
| ./waf configure --without-pch --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --disable-static --enable-shared --boost-libs="$(LIBDIR)" |
| override_dh_auto_install: |
| ./waf install --destdir=debian/tmp |
| .PHONY: override_dh_strip |
| dh_strip --dbg-package=ndn-cxx-dbg |