blob: a136bd962a3660e3fe36090263bbb73cf2ec3b1c [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
# export DH_VERBOSE=1
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
CXXFLAGS += -std=c++11
%:
dh $@ --parallel
override_dh_auto_configure:
CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr
override_dh_auto_build:
./waf build
override_dh_auto_install:
./waf install --destdir=debian/tmp
override_dh_auto_clean:
./waf distclean
override_dh_clean:
dh_clean
./waf distclean
rm -rf .waf-1*
rm -rf .waf3-1*
rm -f .waf-tools/*.pyc
override_dh_auto_test: