ndn-tools: Update to version 0.2 and related fixes
Change-Id: I7e50a73c4e77a50d09414cb6d24e503df05c365a
diff --git a/ndn-tools/debian/rules.precise b/ndn-tools/debian/rules.precise
new file mode 100755
index 0000000..4cd26f1
--- /dev/null
+++ b/ndn-tools/debian/rules.precise
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+
+LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
+CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
+
+%:
+ dh $@ --parallel
+
+override_dh_auto_configure:
+ CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr
+
+override_dh_auto_build:
+ ./waf build
+
+override_dh_auto_install:
+ ./waf install --destdir=debian/tmp
+
+override_dh_auto_clean:
+ ./waf distclean
+
+override_dh_clean:
+ dh_clean
+ ./waf distclean
+ rm -rf .waf-1*
+ rm -rf .waf3-1*
+ rm -f .waf-tools/*.pyc
+ rm -Rf manpages/*.pyc
+
+override_dh_auto_test: