nlsr: install nlsr.conf.sample in /etc/ndn

Remove dependencies that are no longer needed
Restore NLSR github to named-data

refs: #4071, #3992

Change-Id: Ia3aebdf6902e7a254b84f3ae92a42967b7a30b1e
diff --git a/nlsr/debian/rules b/nlsr/debian/rules
index b94084a..8ce273d 100755
--- a/nlsr/debian/rules
+++ b/nlsr/debian/rules
@@ -18,7 +18,7 @@
 	dh $@ --parallel --with=systemd
 
 override_dh_auto_configure:
-	CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --boost-libs="$(LIBDIR)"
+	CXXFLAGS="$(CXXFLAGS)" LINKFLAGS="$(LDFLAGS)" ./waf configure --prefix=/usr --boost-libs="$(LIBDIR)" --sysconfdir=/etc
 
 override_dh_auto_build:
 	./waf build