ndn-cxx: Update to version 0.5.1
Change-Id: Ia5bd34f1ffe11ee5ef90ccefe0abb4224f217841
diff --git a/ndn-cxx/debian/rules b/ndn-cxx/debian/rules
index d879ec1..b5e24b6 100755
--- a/ndn-cxx/debian/rules
+++ b/ndn-cxx/debian/rules
@@ -12,12 +12,13 @@
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
CXXFLAGS += -std=c++11
+LIBDIR := /usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
dh $@ --parallel
override_dh_auto_configure:
- ./waf configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static --enable-shared
+ ./waf configure --prefix=/usr --sysconfdir=/etc --libdir="$(LIBDIR)" --localstatedir=/var --disable-static --enable-shared --boost-libs="$(LIBDIR)"
override_dh_auto_build:
./waf build